EspressChart 7.0 User's Guide


Q. QuickStart
Q.1. Start Chart Designer
Q.2. Start a new chart & setup a data source registry
Q.3. Set up Data Sources in the Registry
Q.4. Build a query
Q.5. Build a chart
Q.6. Customize chart properties
Q.7. Save and export the chart
1. Overview/Introduction
1.1. Using this Guide
1.2. EspressChart Components
1.3. EspressChart Architecture
2. Installation/Configuration
2.1. Running the Installer
2.2. Configuration
2.2.1. Increasing maximum memory heap size for applets
2.3. Starting EspressManager
2.3.1. Starting EspressManager as a Servlet
2.3.1.1. Deploying EspressManager as a Servlet in Tomcat
2.4. Starting Chart Designer
2.4.1. Connecting to EspressManager Running as a Servlet
2.5. Backward compatibility patches
3. Charting Basics
3.1. What is a Chart
3.2. Basic Data Mapping
3.3. Saving and Exporting Charts
3.3.1. Saving Chart Definitions
3.3.2. Generating Image Files
4. Working with Data Sources
4.1. The Data Source Manager
4.1.1. Using Data Source Manager
4.2. Data from a Database
4.2.1. JNDI Data Sources
4.2.2. Queries
4.2.2.1. Using Query Builder
4.2.2.1.1. Tables
4.2.2.1.2. Joins
4.2.2.1.3. Columns
4.2.2.1.4. Using Database Functions
4.2.2.1.5. Adding Extra SQL
4.2.2.1.6. Query Output
4.2.2.2. Parameterized Queries
4.2.2.2.1. Multi-Value Parameters
4.2.2.2.2. Initializing Query Parameters
4.2.2.2.3. All Parameters
4.2.2.3. Entering SQL Statements
4.2.2.3.1. Calling Oracle Stored Procedures
4.2.3. Data Views
4.2.3.1. Data View Parameters
4.2.3.2. Updating Data View Queries
4.2.4. Editing Queries
4.2.5. Editing Database Connections
4.3. Data from XML and XBRL Files
4.3.1. XMLQueries
4.3.1.1. XML Parameters
4.4. Data from Text Files
4.4.1. Formatting Requirements for Text Files
4.4.2. Data Types and Format for Text Files
4.5. Data from Class Files
4.5.1. Parameterized Class Files
4.6. Data from EJBs
4.7. Data from SOAP with WSDL support
4.8. Data from Salesforce
4.9. Data from Excel files
4.10. Using Data for Charts
4.10.1. Using Multiple Data Sources
4.10.2. Change Data Source
4.11. Data Source Updating
5. Chart Types and Data Mapping
5.1. Data Mapping
5.1.1. Data Transposition
5.2. Column Charts
5.2.1. Data Mapping
5.3. Bar Charts
5.3.1. Data Mapping
5.4. XY(Z) Scatter Charts
5.4.1. Data Mapping
5.5. Line Charts
5.5.1. Data Mapping
5.6. Stack Column Charts
5.6.1. Data Mapping
5.7. Stack Bar Charts
5.7.1. Data Mapping
5.8. Pie Charts
5.8.1. Data Mapping
5.9. Area Charts
5.9.1. Data Mapping
5.10. Stack Area Charts
5.10.1. Data Mapping
5.11. High-Low Charts
5.11.1. Data Mapping
5.12. HLCO Charts
5.12.1. Data Mapping
5.13. Percentage Column Charts
5.13.1. Data Mapping
5.14. Doughnut Charts
5.14.1. Data Mapping
5.15. Surface Charts
5.15.1. Data Mapping
5.16. Bubble Charts
5.16.1. Data Mapping
5.17. Overlay Charts
5.17.1. Data Mapping
5.18. Box Charts
5.18.1. Data Mapping
5.19. Radar Charts
5.19.1. Data Mapping
5.20. Dial Charts
5.20.1. Data Mapping
5.20.2. Gauges
5.21. Gantt Charts
5.21.1. Data Mapping
5.22. Polar Charts
5.22.1. Data Mapping
5.23. Changing Data Mapping or Data Source
6. The Designer Interface
6.1. The Designer Menus
6.1.1. File Menu
6.1.2. Insert Menu:
6.1.3. Format Menu
6.1.4. Type Menu
6.1.5. Drill-Down Menu
6.1.6. Data Menu
6.1.7. Help Menu
6.1.8. Layout Menu
6.2. The Designer Toolbar
6.3. Color, Color set, Pattern, and Font Panels
6.3.1. Color Panel
6.3.2. Color Set Panel
6.3.2.1. Save Colors for Categories feature
6.3.3. Pattern Panel
6.3.4. Font Panel
6.4. The Navigation Panel
6.5. The Viewport
6.5.1. The Chart Canvas
6.5.1.1. Background Images
6.5.2. Moving and Sizing Chart Elements
6.6. Adding Chart Elements
6.6.1. Adding Text
6.6.1.1. TextVariables
6.6.1.2. Text Replacement
6.6.1.3. Automatic Text Resizing
6.6.1.4. Text Cropping
6.6.2. Adding Lines
6.6.2.1. Line and Point Formatting
6.6.2.2. Floating Lines
6.6.2.3. Fixed Horizontal/Vertical Lines
6.6.2.3.1. Multiple control lines for Stack Type Charts
6.6.2.4. Trend Lines
6.6.2.4.1. Normal Distribution Curve
6.6.3. Adding Control Areas
6.6.4. Adding Tables
6.6.5. Adding Hyperlinks
6.6.5.1. Viewing Hyperlinks
6.7. Formatting Chart Axes
6.7.1. Axis Scale
6.7.2. Axis Elements
6.7.2.1. Axis Label Formatting
6.8. Formatting Plot/Data Elements
6.8.1. Data Properties
6.8.2. Date/Time Based Zooming
6.8.2.1. Adding Zooming
6.8.2.2. Zooming In Chart Viewer
6.8.3. Data Ordering
6.8.3.1. Top/Bottom N Charts
6.8.4. Histograms
6.8.5. Formatting Plot Area
6.8.6. Formatting Chart Legend
6.8.7. 3D Display Options
6.8.8. Data Border
6.8.9. Aggregation
6.9. Chart-Specific Options
6.9.1. Bubble Charts
6.9.2. Dial Charts
6.9.2.1. Gauge Images
6.9.3. Overlay Charts
6.9.4. Pie Charts
6.9.5. Line Charts:
6.9.5.1. Double Value Line Charts
6.9.6. HLCO Charts
6.9.7. Box Charts
6.9.8. Stack Area Charts
6.9.9. Gantt Charts
6.9.10. Radar Charts
6.9.11. Scatter Charts
6.9.12. Polar Charts
6.9.13. Column Charts with Series
6.9.14. Column/Bar Charts without Series
6.9.15. Two-Dimensional Line Combination Charts
6.9.16. Doughnut Charts
6.10. Chart Designer in Mac OS X
7. Drill-Down
7.1. Data Drill-Down
7.1.1. Adding Data Drill-Down
7.2. Dynamic Data Drill-Down
7.3. Parameter Drill-Down
7.3.1. Adding Parameter Drill-Down
8. Saving & Exporting Charts
8.1. Saving Charts
8.1.1. Working with Templates
8.1.2. Saving XML Templates
8.1.3. Creating a Viewer Page
8.1.3.1. Viewer Options
8.2. Exporting Charts
8.2.1. PDF Font Mapping
8.2.1.1. PDF Font Mapping Import/Export
9. Chart Viewer
9.1. The Chart Viewer Parameters
9.2. Specifying the Data Source for Chart Viewer
9.2.1. Data Read From a Database
9.2.2. Data Read From a Data File
9.2.3. Data Read From an Argument
9.3. Using Chart Viewer
9.4. Axis Rulers
9.5. Parameter Server
9.6. Pop-up Menu
9.6.1. Changing Chart Dimension and Type
9.6.2. Axis Zooming
9.6.3. Zooming
9.6.4. Dynamic Data Drill-Down
9.6.5. Query Parameter
9.7. Swing Version Available
10. EspressChart Chart API
10.1. Introduction and Setup
10.2. Recommended Approach for Using Chart API
10.3. Interaction with EspressManager
10.4. Connecting to EspressManager
10.4.1. EspressManager Running as Application
10.4.2. EspressManager Running as Servlet
10.5. Using the API
10.5.1. Loading a Chart
10.5.1.1. Parameterized Charts
10.5.1.1.1. Object Array
10.5.2. Applying a Chart Template
10.5.3. Modifying Data Source
10.5.3.1. Data from a Database
10.5.3.1.1. JNDI
10.5.3.2. Data from a Data File (TXT/DAT/XML)
10.5.3.3. Data from an XML Data Source
10.5.3.4. Data from Custom Implementation
10.5.3.5. Data passed in an Array in Memory
10.5.4. Modifying Chart Attributes
10.5.4.1. Modifying Color, Font, ...
10.5.4.2. Setting Predefined Patterns
10.5.4.3. Setting Customized Patterns
10.5.4.4. Modifying Size
10.5.4.5. Modifying Date/Time Zoom Charts
10.5.5. Exporting the Chart
10.5.5.1. Record File Exporting
10.5.5.2. Streaming Charts
10.5.6. Calling Chart Designer from Chart API
10.5.6.1. Specify a Chart Template
10.5.6.2. Specify a Data Registry
10.5.6.3. Specify a DBInfo Object (Database Information)
10.5.6.4. Open Query Builder with a Specified DBInfo Object (Database Information)
10.5.6.5. Open Chart Designer with pre-set Directories
10.5.6.6. Open Chart Designer with Modified Menubar and Toolbar
10.6. API Only Features
10.6.1. Visual
10.6.1.1. Canvas/Plot
10.6.1.1.1. Customizable Message for No-Data-In-Plot
10.6.1.1.2. Set Chart to Fit Canvas
10.6.1.1.3. Set Chart Invisible
10.6.1.1.4. Applying Different Graphics Rendering
10.6.1.1.5. Chart Plot Position
10.6.1.1.6. Drawing Multiple Charts in same Plot
10.6.1.2. Hint Box
10.6.1.2.1. Modify Hint Box
10.6.1.2.2. Data and Hyperlink Hint Box Offset
10.6.1.2.3. Hint Box Border Color
10.6.1.2.4. Customize Image Map Hint Box
10.6.1.3. Legend/Annotation
10.6.1.3.1. Annotation with Symbol
10.6.1.3.2. Set Relative Shift of Annotation Border
10.6.1.3.3. Set Reference Position of Legend and Annotation Text
10.6.1.4. Misc.
10.6.1.4.1. Ticker Label Replacement
10.6.1.4.2. Customizable Data Top Label
10.6.1.4.3. Show Axis as Date/Time/Timestamp
10.6.1.4.4. Selective String Rendering
10.6.1.4.5. Drawing Data Points above Horizonval/Vertical/Trend Lines
10.6.2. Data
10.6.2.1. Getting the Coordinates
10.6.2.2. Set Data Limit at Axis Scale
10.6.2.3. Set Null Data as Zero
10.6.2.4. Additional Trend Line Options
10.6.2.5. Adding Multiple Control Lines to Stack Type Chart
10.6.3. Chart Specific
10.6.3.1. Column/Bar Charts
10.6.3.1.1. Color Separator
10.6.3.1.2. Disabling Shadow
10.6.3.2. Pie Charts
10.6.3.2.1. Drawing Pie Slices Clockwise/Counter Clockwise
10.6.3.2.2. Pie Border for 0% and 100% Slices
10.6.3.2.3. Customize Separator between Category and Percent Value Strings in Pie Legend
10.6.3.2.4. Pie Border Color Customizable
10.6.3.3. Line Charts
10.6.3.3.1. Line Area
10.6.3.4. Scatter Charts
10.6.3.4.1. Show Series in Top Label
10.6.3.4.2. Drawing Order
10.6.3.4.3. Scatter Chart Cube Width
10.6.3.5. Overlay Charts
10.6.3.5.1. Multiple Axes Titles
10.6.3.6. Dial Charts
10.6.3.6.1. Control Area Scale Labels
10.6.3.7. HLCO Charts
10.6.3.7.1. Changing Candle Stick Color
10.6.3.7.2. Changing Candle Stick Wicker Width
10.6.3.8. Surface Charts
10.6.3.8.1. Heat Map
10.6.4. Performance
10.6.4.1. BufferedImage or Frame
10.6.4.2. Chart Generation Order
10.6.5. Viewer
10.6.5.1. Call Back Mechanism
10.6.5.2. Disable/Enable Tool Tips Text
10.6.5.3. Canvas Area
10.7. Changing Chart Viewer Options
10.8. Javadoc
10.9. Swing Version
10.10. Summary
10.A. Getting the Chart Data
10.A.1. Data from a Database
10.A.1.1. JNDI
10.A.2. Data from a Data file (TXT/DAT/XML)
10.A.3. Data from a XML Data Source
10.A.4. Data Passed in an Array in Memory
10.A.5. Data Passed in your Custom Implementation
10.A.6. Data from a Spreadsheet Model
10.A.7. Data from Enterprise Java Beans (EJBs)
10.A.8. Data from a SOAP Data Source
10.A.8.1. Example SOAP Service
10.A.9. Data from multiple Data Sources
10.A.10. Data in Spreadsheet Format
10.A.11. Transposing Data
10.A.11.1. Non-Selective Transposing
10.A.11.2. Selective Transposing
10.B. Creating the Chart
10.B.1. Column, Bar, Line, Area, Pie and Overlay Charts
10.B.1.1. Column Mapping
10.B.1.2. Creating the Chart
10.B.2. Radar Charts
10.B.2.1. Column Mapping
10.B.2.2. Creating the Chart
10.B.3. XY(Z) Scatter Charts
10.B.3.1. Column Mapping
10.B.3.2. Creating the Chart
10.B.4. Stack Column, Percentage Column, Stack Bar and Stack Area Charts
10.B.4.1. Column Mapping
10.B.4.2. Creating the Chart
10.B.5. Dial Charts
10.B.5.1. Column Mapping
10.B.5.2. Creating the Chart
10.B.6. Box Charts
10.B.6.1. Column Mapping
10.B.6.2. Creating the Chart
10.B.7. Bubble Charts
10.B.7.1. Column Mapping
10.B.7.2. Creating the Chart
10.B.8. High-Low and HLCO Charts
10.B.8.1. Column Mapping
10.B.8.2. Creating the Chart
10.B.9. Surface Charts
10.B.9.1. Column Mapping
10.B.9.2. Creating the Chart
10.B.10. Gantt Charts
10.B.10.1. Column Mapping
10.B.10.2. Creating the Chart
10.B.11. Polar Charts
10.B.11.1. Column Mapping
10.B.11.2. Creating the Chart
10.B.12. Date/Time Based Zoom Charts
10.B.13. Parameterized Charts
10.B.14. Drill-Down Charts
10.B.14.1. Parameter Drill-Down Charts
10.B.14.2. Data Drill-Down Charts
10.B.14.3. Dynamic Data Drill-Down Charts
11. Servlets and JavaServer Pages
11.1. Servlets
11.1.1. Introduction
11.1.2. Setup
11.1.3. Running Under
11.1.3.1. Apache Tomcat
11.1.3.2. JRun
11.1.3.3. ColdFusion Server
11.1.3.4. WebLogic 6.0
11.1.3.4.1. WebLogic 9.2
11.1.3.5. WebSphere 3.5
11.1.3.5.1. WebSphere 6.1
11.1.3.6. JBoss 4.0.5
11.1.3.7. Orion 2.0.7
11.1.3.8. JRun 4 (with Update 6)
11.1.3.9. Oracle 10g (10.1.3.1.0)
11.1.3.10. Sun Java System Application PE (9.0, 8.2)
11.1.3.11. Sun Java System WebServer 7.0
11.1.3.12. Resing 3.1.0
11.1.3.13. ColdFusion MX 7.02
11.1.4. Running the Servlet
11.2. JavaServer Pages (JSP)
11.2.1. Introduction
11.2.2. Running Under
11.2.2.1. Apache Tomcat
11.2.2.2. WebSphere
11.3. Saving a Chart to File versus Sending it to a Browser
11.3.1. Saving the Chart to a File
11.3.2. Sending the Chart Directly to a Browser
12. Deployment
12.1. Introduction
12.2. Deploying with EspressManager
12.2.1. Chart Designer
12.2.2. Chart Viewer
12.2.3. Chart API
12.3. Deploying without EspressManager
12.3.1. Chart Viewer
12.3.2. Chart API
12.4. Deploying in a Non-Windows Enviroment
12.4.1. Xvfb (X Virtual Frame Buffer)
12.4.2. JVM 1.4+ in Headless Mode
12.5. Platform Specific Issues
12.5.1. AS/400
12.5.1.1. Running under NAWT
12.5.1.2. Running under Headless Mode
12.5.2. Linux/Unix
12.5.2.1. Running under X
12.5.2.2. Running under Headless Mode
13. Internationalization
13.1. Internationalizing EspressChart
13.1.1. Specifying Locales
13.1.1.1. Locale-Specific Formatting
13.1.1.2. Setting Time Zones and Locales Using the API
13.1.2. Language and Encoding
13.1.2.1. EspressChart Language Translation
13.1.2.1.1. Upgrading Language File
13.1.2.2. Displaying Foreign Characters
13.1.2.3. Entering Foreign Characters
13.1.2.4. XML Encoding
A. Parameter Server
A.1. Writing a Parameter Server
A.1.1. Variables
A.1.2. Constructor
A.1.3. Methods
B. Customizing Chart Layout
B.1. Changing the Chart Plot Area
B.2. Changing the Canvas Area
B.3. Fit Charts Elements
B.4. Changing Position of Legend Box
B.5. Attaching Labels to Datapoints